viernes, 20 de marzo de 2015

Resumen De La Famosa Actualización de OpenSSL

Últimamente estoy hablando bastante de OpenSSL y es porque, ayer salió la una actualización que corregía múltiples vulnerabilidades de severidad elevadas, pero no fue hasta la tarde noche cuando vi el listado actualizado de errores que parcheaba así que no puede hacer la entrada como quería y os acabé hablando de RC4. 

Hoy si que he podido leerme el report entero y haceros un resumen de lo que contiene. 


OpenSSL ha publicado una actualización sobre las vulnerabilidades que son corregidas con este parche:
  • CVE-2015-0207: Un error en la función "DTLSv1_listen()" en ssl/d1_lib.c permite causar una caída del servicio. 
  • CVE-2015-0208: Un error en ASN-1 de los parámetros de RSA PSS puede ser explotada para activar un NULL pointer dereference error. 
  • CVE-2015-0286: Un error en la función ASN1_TYPE_cmp() puede provocar la caída del servicio. 
  • CVE-2015-0287: Un error no especificado relacionad con ASN.1 permite la escritura invalida en la memoria. 
  • CVE-2015-0289: Un error en las firmas ContentInfo of PKCS#7 puede ser explotada para activar un puntero NULL pointer dereference error.
  • CVE-2015-0290: Un error relacionado con la implementación de “multiblock” permite la caída del servicio. 
  • CVE-2015-0291: Este error también puede ser explotado para activar un puntero NULL pointer dereference error. 
  • CVE-2015-0293: Un error en SSLv2 CLIENT-MASTER-KEY messages puede ser explotado para causar un OPENSSL_assert. 
  • CVE-2015-1787: Un error en el cifrado DHE cipher suite puede causar la caída del sistema. 
  • CVE-2015-0209: Un error en la función “d2i_ECPrivateKey()” en crypto/ec/ec_asn1.c permite la activación de una condición después de la explotación. 
  • CVE-2015-0285: Un error de referencia en un puntero Null en la función X509_to_X509_REQ() de crypto/x509/x509_req.c permite al atacante causar una caída del sistema. 
  • CVE-2015-0288: Otro fallo con la función “ssl3_client:hello()” en ssl/s3_clnt.c puede permitir ataques no especificados. 

Solución:
  • Actualizar a las versiones 1.0.2a, 1.0.1m, 1.0.0r, o 0.9.8zf.
Más información:
Espero que os haya servido.
Sed Buenos con esto 0;) 

No hay comentarios:

Publicar un comentario